ListBoxEx Plugin Help

ToolBar Plugin

Welcome

ToolBar Object Plugin Help File

Plugin Name :

ToolBar

Current Version :

1.0.0.0

Last Update :

03/05/2009 (dd/mm/yyyy)

System Requirements :

Requires Win2000 Or Above

Additional Dependencies :

None

Licence :

Commercial

Author :

www.amsplugins.com

Web :

www.amsplugins.com

E-mail :

support@amsplugins.com

Copyright :

The ToolBar plugin is copyright © 2008 www.amsplugins.com.

Credits :

AMS ActionFile Editor Is Mostly Used On Creation Of This Help File

Copyright © 2008 - 2009 www.amsplugins.com
All Rights Reserved.


ToolBar Plugin

Events

Events

On Setup

Fires during object creation Tip : set image list and object style at this time.

OnLButtonDown

Fires when the left mouse button down on a toolbar button.

e_ButtonID:

(number) The id of the current button.

e_X:

(number) The x position of cursor at this time.

e_Y:

(number) The y position of cursor at this time.

OnLButtonUp

Fires when the left mouse button up on a toolbar button

e_ButtonID:

(number) The id of the current button.

e_X:

(number) The x position of cursor at this time.

e_Y:

(number) The y position of cursor at this time.

OnButtonHighLight

Fires when the user moves mouse over a toolbar button

e_ButtonID:

(number) The id of the current button.

e_X:

(number) The x position of cursor at this time.

e_Y:

(number) The y position of cursor at this time.

OnMouseMove

Fires when the user moves mouse over a toolbar

e_X:

(number) The x position of cursor at this time.

e_Y:

(number) The y position of cursor at this time.


ListBoxEx Plugin Help

LiToolBar Plugin

Properties

Properties

Back Color

The background color of ListBoxEx object. you can select a color via color picker .

Border Style

The border style of ToolBar object. you can select one of following None , Flat , Sunken ,Bevel .
None : no border
Flat : a thin-line border
Sunken : a border with a sunken edge
Bevel : a border with a raised edge

Icon Width

The width (in pixel) of individual Icons in a toolbar object.

Icon Height

The height (in pixel) of individual icons in a toolbar object.

Icon H Spacing

The horizontal icon spacing (in pixel) of individual buttons in a toolbar object (horizontal space between icon and button border).

Icon V Spacing

The vertical icon spacing (in pixel) of individual buttons in a toolbar object (vertical space between icon and button border).

Button H Spacing

(number) The horizontal spacing (in pixel) of individual buttons in a toolbar object (horizontal space around of a button border). Note: this value must be same with "Icon H Spacing" or greater

Button V Spacing

(number) The vertical spacing (in pixel) of individual buttons in a toolbar object (horizontal space around of a button border). Note: this value must be same with "Icon V Spacing" or greater.

Copyright © 2008 Reteset.


ToolBar.SetToolTipsVisible

ToolBar.SetToolTipsVisible (

(string) ObjectName,

(boolean) Visible )

Description

Sets the visibility of tooltips.

Parameters

ObjectName

(string) The name of the object.

Visible

(boolean) Whether to make the tooltips visible or invisible.

Returns

This action dose not return any value.


ToolBar.SetToolTipsBorderStyle

ToolBar.SetToolTipsBorderStyle (

(string) ObjectName,

(number) BorderStyle )

Description

Sets the border style of tooltips in toolbar.

Parameters

ObjectName

(string) The name of the object.

BorderStyle

(number) The border style of tooltips.

CONSTANT | VALUE | DESCRIPTION
BUTTON_BDR_NONE | 0 | No border
BUTTON_BDR_FLAT | 1 | Thin line border
BUTTON_BDR_SUNKEN | 2 | Sunken border
BUTTON_BDR_RAISED | 3 | Raised border
BUTTON_BDR_COLOR | 4 | Thin and colorful border

Returns

This action dose not return any value.


ToolBar.SetToolTipGradient

ToolBar.SetToolTipGradient (

(string) ObjectName,

(number) Style,

(table) GradientColors )

Description

Sets gradient colors of the toolbar's tooltip.

Parameters

ObjectName

(string) The name of the object.

Style

(number) The style of gradient effect.

CONSTANT | VALUE | DESCRIPTION
VERTICAL | 0 | Vertical gradient style
HORIZONTAL | 1 | Horizontal gradient style
BACKWARD_DIAGONAL | 2 | Backward diagonal gradient style
FORWARD_DIAGONAL | 3 | Forward diagonal gradient style

GradientColors

(table) The gradient color table. A numerically indexed table that contains color values. This table may contain maximum 30 and Minimum 2 indexes. Set nil for use default back color.

Returns

This action dose not return any value.

Example:

ToolBar.SetToolTipGradient("Plugin1", FORWARD_DIAGONAL, {16316664,16764057,16316664});


ToolBar.SetToolTipBackColor

ToolBar.SetToolTipBackColor (

(string) ObjectName,

(number) BackColor )

Description

Sets the background color of the toolbar's tooltip.

Parameters

ObjectName

(string) The name of the object.

BackColor

(number) The background color of toolbar's tooltip.

Returns

This action dose not return any value.


ToolBar.SetSize

ToolBar.SetSize (

(string) ObjectName,

(number) Width,

(number) Height )

Description

Sets the size of a toolbar object.

Parameters

ObjectName

(string) The name of the object.

Width

(number) The new width of object.

Height

(number) The new height of object .

Returns

This action dose not return any value.


ToolBar.SetPos

ToolBar.SetPos (

(string) ObjectName,

(number) X,

(number) Y )

Description

Sets the position of a toolbar object.

Parameters

ObjectName

(string) The name of the object.

X

(number) The new X position of object.

Y

(number) The new Y position of object .

Returns

This action dose not return any value.


ToolBar.SetMarkerColor

ToolBar.SetMarkerColor (

(string) ObjectName,

(number) Color )

Description

Sets color of the button markers.

Parameters

ObjectName

(string) The name of the object.

Color

(number) The decimal color value of button markers.

Returns

This action dose not return any value.


ToolBar.SetImageList

ToolBar.SetImageList (

(string) ObjectName )

Description

Sets the image list of a toolbar object.

Parameters

ObjectName

(string) The name of the object.

Returns

This action dose not return any value.


ToolBar.SetEnabled

ToolBar.SetEnabled (

(string) ObjectName,

(boolean) Enable )

Description

Sets the enabled/disabled state of a toolbar object.

Parameters

ObjectName

(string) The name of the object.

Enable

(boolean) Whether to make the toolbar object enabled or disabled.

Returns

This action dose not return any value.


ToolBar.SetButtonStateIcon

ToolBar.SetButtonStateIcon (

(string) ObjectName,

(number) ButtonId,

(number) State,

(number) NewIcon )

Description

Sets a new icon for a state of a specified button.

Parameters

ObjectName

(string) The name of the object.

ButtonId

(number) The id of the button.

State

(number) The state of the button to be set the new icon.

CONSTANT | VALUE | DESCRIPTION
STATE_NORMAL | 0 | The normal state of buttons
STATE_HIGHLIGHT | 1 | The highlight state of buttons
STATE_DOWN | 2 | The down state of buttons

NewIcon

(number) The (zero based)index of icon to be set to a button state.

Returns

This action dose not return any value.


ToolBar.SetButtonSize

ToolBar.SetButtonSize (

(string) ObjectName,

(number) IconWidth,

(number) IconHeight,

(number) HorzIconSpacing,

(number) VertIconSpacing,

(number) HorzSpacing,

(number) VertSpacing )

Description

Sets size of the individual buttons in toolbar object (Appylies to all buttons).

Parameters

ObjectName

(string) The name of the object.

IconWidth

(number) The width (in pixel) of individual Icons in a toolbar object.

IconHeight

(number) The height (in pixel) of individual icons in a toolbar object.

HorzIconSpacing

(number) The horizontal icon spacing (in pixel) of individual buttons in a toolbar object (horizontal space between icon and button border).

VertIconSpacing

(number) The vertical icon spacing (in pixel) of individual buttons in a toolbar object (vertical space between icon and button border).

HorzSpacing

(number) The horizontal spacing (in pixel) of individual buttons in a toolbar object (horizontal space around of a button border). Note: this value must be same with "HorzIconSpacing" or greater

VertSpacing

(number) The vertical spacing (in pixel) of individual buttons in a toolbar object (horizontal space around of a button border). Note: this value must be same with "VertIconSpacing" or greater.

Returns

This action dose not return any value.


ToolBar.SetButtonMarker

(boolean) ToolBar.SetButtonMarker (

(string) ObjectName,

(number) ButtonId,

(boolean) Visible )

Description

Sets the marker of a button is visible or invisible.

Parameters

ObjectName

(string) The name of the object.

ButtonId

(number) The id of the button.

Visible

(boolean) Specifies the visibility state of the button's marker.

CONSTANT | VALUE | DESCRIPTION
true | NA | Button marker is visible
false | NA | Button marker is nvisible

Returns

(boolean) Returns true on success and returns false on fail


ToolBar.SetButtonGradient

ToolBar.SetButtonGradient (

(string) ObjectName,

(number) State,

(number) Style,

(table) GradientColors )

Description

Sets gradient colors of the buttons in toolbar object (Appylies to all buttons).

Parameters

ObjectName

(string) The name of the object.

State

(number) The state of buttons to be set the gradient colors.

CONSTANT | VALUE | DESCRIPTION
STATE_NORMAL | 0 | The normal state of buttons
STATE_HIGHLIGHT | 1 | The highlight state of buttons
STATE_DOWN | 2 | The down state of buttons

Style

(number) The style of gradient effect.

CONSTANT | VALUE | DESCRIPTION
VERTICAL | 0 | Vertical gradient style
HORIZONTAL | 1 | Horizontal gradient style
BACKWARD_DIAGONAL | 2 | Backward diagonal gradient style
FORWARD_DIAGONAL | 3 | Forward diagonal gradient style

GradientColors

(table) The gradient color table. A numerically indexed table that contains color values. This table may contain maximum 30 and Minimum 2 indexes. Set nil for use default button back color.

Returns

This action dose not return any value.

Example:

ToolBar.SetButtonGradient("Plugin1", STATE_HIGHLIGHT, VERTICAL, {16316664,16764057,16764057,16764057});
ToolBar.SetButtonGradient("Plugin1", STATE_DOWN, FORWARD_DIAGONAL, {16316664,13408767,16316664});
ToolBar.SetButtonGradient("Plugin1", STATE_NORMAL, HORIZONTAL, {16316664,13408767,16316664});


ToolBar.SetButtonData

(boolean) ToolBar.SetButtonData (

(string) ObjectName,

(number) ButtonId,

(string) Data )

Description

Sets the data of a button in a toolbar object.

Parameters

ObjectName

(string) The name of the object.

ButtonId

(number) The id of the button.

Data

(string) A multi purpose data field for buttons. Can hold any amount of string data.

Returns

(boolean) Returns true on success and returns false on failure


ToolBar.SetButtonBorderStyle

ToolBar.SetButtonBorderStyle (

(string) ObjectName,

(number) State,

(number) BorderStyle )

Description

Sets the border style of a button state in toolbar (Appylies to all buttons).

Parameters

ObjectName

(string) The name of the object.

State

(number) The state of buttons to be set the border style.

CONSTANT | VALUE | DESCRIPTION
STATE_NORMAL | 0 | The normal state of buttons
STATE_HIGHLIGHT | 1 | The highlight state of buttons
STATE_DOWN | 2 | The down state of buttons

BorderStyle

(number) The border style of specified button state.

CONSTANT | VALUE | DESCRIPTION
BUTTON_BDR_NONE | 0 | No border
BUTTON_BDR_FLAT | 1 | Thin line border
BUTTON_BDR_SUNKEN | 2 | Sunken border
BUTTON_BDR_RAISED | 3 | Raised border
BUTTON_BDR_COLOR | 4 | Thin and colorful border

Returns

This action dose not return any value.


ToolBar.SetButtonBorderColor

ToolBar.SetButtonBorderColor (

(string) ObjectName,

(number) State,

(number) BackColor )

Description

Sets the border color of a button state in toolbar (if border style is set to color).

Parameters

ObjectName

(string) The name of the object.

State

(number) The state of buttons to be set the border color.

CONSTANT | VALUE | DESCRIPTION
STATE_NORMAL | 0 | The normal state of buttons
STATE_HIGHLIGHT | 1 | The highlight state of buttons
STATE_DOWN | 2 | The down state of buttons

BackColor

(number) The frame color of specified button state.

Returns

This action dose not return any value.


ToolBar.SetButtonBackColor

ToolBar.SetButtonBackColor (

(string) ObjectName,

(number) State,

(number) BackColor )

Description

Sets the background color of a button state in toolbar (Appylies to all buttons).

Parameters

ObjectName

(string) The name of the object.

State

(number) The state of buttons to be set the background color.

CONSTANT | VALUE | DESCRIPTION
STATE_NORMAL | 0 | The normal state of buttons
STATE_HIGHLIGHT | 1 | The highlight state of buttons
STATE_DOWN | 2 | The down state of buttons

BackColor

(number) The background color of specified button state.

Returns

This action dose not return any value.


ToolBar.SetBackgroundGradient

ToolBar.SetBackgroundGradient (

(string) ObjectName,

(number) Style,

(table) GradientColors )

Description

Sets background gradient colors of a toolbar object.

Parameters

ObjectName

(string) The name of the object.

Style

(number) The style of gradient effect.

CONSTANT | VALUE | DESCRIPTION
VERTICAL | 0 | Vertical gradient style
HORIZONTAL | 1 | Horizontal gradient style
BACKWARD_DIAGONAL | 2 | Backward diagonal gradient style
FORWARD_DIAGONAL | 3 | Forward diagonal gradient style

GradientColors

(table) The gradient color table. A numerically indexed table that contains color values. This table may contain maximum 30 and Minimum 2 indexes. Set nil for use default background color. or remove existing gradient

Returns

This action dose not return any value.

Example:

ToolBar.SetBackgroundGradient("Plugin1", VERTICAL, {10092543,46819,10092543});


ToolBar.SetBackgroundColor

ToolBar.SetBackgroundColor (

(string) ObjectName,

(number) BackColor )

Description

Sets background color of a toolbar object.

Parameters

ObjectName

(string) The name of the object.

BackColor

(number) The decimal color value of toolbar background.

Returns

This action dose not return any value.


ToolBar.ReplaceIcon

ToolBar.ReplaceIcon (

(string) ObjectName,

(number) IconIndex,

(string) NewIcon )

Description

Replaces an icon in previously created image list with new one.

Parameters

ObjectName

(string) The name of the object.

IconIndex

(number) The index of icon in image list.

NewIcon

(string) The path to new icon file.

Returns

This action dose not return any value.


ToolBar.IsVisible

(boolean) ToolBar.IsVisible (

(string) ObjectName )

Description

Retruns true if specified toolbar object is visible. and false if it is not.

Parameters

ObjectName

(string) The name of the object.

Returns

(boolean) Retruns true if specified toolbar object is visible. and false if it is not.


ToolBar.IsToolTipsVisible

(boolean) ToolBar.IsToolTipsVisible (

(string) ObjectName )

Description

Retruns true if tooltips are visible. and false if they are not.

Parameters

ObjectName

(string) The name of the object.

Returns

(boolean) Retruns true if tooltips are visible. and false if they are not.


ToolBar.IsEnabled

(boolean) ToolBar.IsEnabled (

(string) ObjectName )

Description

Retruns true is specified toolbar object is enabled. and false if it is disabled.

Parameters

ObjectName

(string) The name of the object.

Returns

(boolean) Retruns true is specified toolbar object is enabled. and false if it is disabled.


ToolBar.IsButtonToolTipEnabled

(boolean) ToolBar.IsButtonToolTipEnabled (

(string) ObjectName,

(number) ButtonId )

Description

Gets the tooltip state of a button is visible or invisible.

Parameters

ObjectName

(string) The name of the object.

ButtonId

(number) The id of the button.

Returns

(boolean) Returns true if specified button's tooltip is visible and returns false if specified button's tooltip is invisible


ToolBar.IsButtonEnabled

(boolean) ToolBar.IsButtonEnabled (

(string) ObjectName,

(number) ButtonId )

Description

Determines whether specified toolbar button is enabled or not.

Parameters

ObjectName

(string) The name of the object.

ButtonId

(number) The id of the button.

Returns

(boolean) Returns true if specified button is enabled , and false if it is disabled


ToolBar.GetToolTipsBorderStyle

(number) ToolBar.GetToolTipsBorderStyle (

(string) ObjectName )

Description

Gets the border style of tooltips in toolbar.

Parameters

ObjectName

(string) The name of the object.

Returns

(number) Returns one of following

CONSTANT

VALUE

DESCRIPTION

BUTTON_BDR_NONE

0

No border

BUTTON_BDR_FLAT

1

Thin line border

BUTTON_BDR_SUNKEN

2

Sunken border

BUTTON_BDR_RAISED

3

Raised border

BUTTON_BDR_COLOR

4

Thin and colorful border


ToolBar.GetToolTipBackColor

(number) ToolBar.GetToolTipBackColor (

(string) ObjectName )

Description

Gets the background color of the toolbar's tooltip.

Parameters

ObjectName

(string) The name of the object.

Returns

(number) The decimal color value of tooltip's background color


ToolBar.GetSize

(table) ToolBar.GetSize (

(string) ObjectName )

Description

Gets the size of a toolbar object.

Parameters

ObjectName

(string) The name of the object.

Returns

(table) returns a table containing object dimensions
table indexes are : Width and Height
returs nil if an error occurs


ToolBar.GetPos

(table) ToolBar.GetPos (

(string) ObjectName )

Description

Gets the position of a toolbar object.

Parameters

ObjectName

(string) The name of the object.

Returns

(table) returns a table containing object position
table indexes are : X and Y
returs nil if an error occurs


ToolBar.GetMarkerColor

(number) ToolBar.GetMarkerColor (

(string) ObjectName )

Description

Gets color of the button markers.

Parameters

ObjectName

(string) The name of the object.

Returns

(number) The decimal color value of markers


ToolBar.GetButtonMarker

(boolean) ToolBar.GetButtonMarker (

(string) ObjectName,

(number) ButtonId )

Description

Gets the marker state of a button is visible or invisible.

Parameters

ObjectName

(string) The name of the object.

ButtonId

(number) The id of the button.

Returns

(boolean) Returns true if marker is visible and returns false if marker is invisible


ToolBar.GetButtonData

(string) ToolBar.GetButtonData (

(string) ObjectName,

(number) ButtonId )

Description

Gets the data of a button in a toolbar object.

Parameters

ObjectName

(string) The name of the object.

ButtonId

(number) The id of the button.

Returns

(string) Returns the data of specified button if it is exist , and returns empty string "" if it is not exist


ToolBar.GetButtonBorderStyle

(number) ToolBar.GetButtonBorderStyle (

(string) ObjectName,

(number) State )

Description

Gets the border style of a button state in toolbar.

Parameters

ObjectName

(string) The name of the object.

State

(number) The state of buttons to be get the border style.

CONSTANT | VALUE | DESCRIPTION
STATE_NORMAL | 0 | The normal state of buttons
STATE_HIGHLIGHT | 1 | The highlight state of buttons
STATE_DOWN | 2 | The down state of buttons

Returns

(number) Returns one of fallowing

CONSTANT

VALUE

DESCRIPTION

BUTTON_BDR_NONE

0

No border

BUTTON_BDR_FLAT

1

Thin line border

BUTTON_BDR_SUNKEN

2

Sunken border

BUTTON_BDR_RAISED

3

Raised border

BUTTON_BDR_COLOR

4

Thin and colorful border


ToolBar.GetButtonBorderColor

(number) ToolBar.GetButtonBorderColor (

(string) ObjectName,

(number) State )

Description

Gets the border color of a button state in toolbar.

Parameters

ObjectName

(string) The name of the object.

State

(number) The state of buttons to be retrieved the border color.

CONSTANT | VALUE | DESCRIPTION
STATE_NORMAL | 0 | The normal state of buttons
STATE_HIGHLIGHT | 1 | The highlight state of buttons
STATE_DOWN | 2 | The down state of buttons

Returns

(number) The decimal color value of specified button's border color


ToolBar.GetButtonBackColor

(number) ToolBar.GetButtonBackColor (

(string) ObjectName,

(number) State )

Description

Gets the background color of a button state in toolbar.

Parameters

ObjectName

(string) The name of the object.

State

(number) The state of buttons to be retrieved the background color.

CONSTANT | VALUE | DESCRIPTION
STATE_NORMAL | 0 | The normal state of buttons
STATE_HIGHLIGHT | 1 | The highlight state of buttons
STATE_DOWN | 2 | The down state of buttons

Returns

(number) The decimal background color value of specified button state


ToolBar.GetBackgroundColor

(number) ToolBar.GetBackgroundColor (

(string) ObjectName )

Description

Gets background color of a toolbar object.

Parameters

ObjectName

(string) The name of the object.

Returns

(number) The decimal value of toolbar background color


ToolBar.EnableButtonToolTip

(boolean) ToolBar.EnableButtonToolTip (

(string) ObjectName,

(number) ButtonId,

(boolean) Visible )

Description

Sets the tooltip of a button is visible or invisible.

Parameters

ObjectName

(string) The name of the object.

ButtonId

(number) The id of the button.

Visible

(boolean) Specifies the visibility state of the button's tooltip.

Returns

(boolean) returns true on succeed false on failed


ToolBar.EnableButton

(boolean) ToolBar.EnableButton (

(string) ObjectName,

(number) ButtonId,

(boolean) Enable )

Description

Enables or disables a button in a toolbar object.

Parameters

ObjectName

(string) The name of the object.

ButtonId

(number) The id of the button.

Enable

(boolean) Whether to make a button enabled or disabled.

Returns

(boolean) returns true on succeed false on failed


ToolBar.DeleteButton

(boolean) ToolBar.DeleteButton (

(string) ObjectName,

(number) ButtonId )

Description

Deletes a button from a toolbar object.

Parameters

ObjectName

(string) The name of the object.

ButtonId

(number) The id of the button.

Returns

(boolean) returns true on succeed false on failed


ToolBar.CreateImageList

(boolean) ToolBar.CreateImageList (

(string) ObjectName )

Description

Prepares a image list for a toolbar object.

Parameters

ObjectName

(string) The name of the object.

Returns

(boolean) returns true on succeed false on failed

Example:

bImagelist = ToolBar.CreateImageList("Plugin1");

if ( bImagelist ) then

   ToolBar.AddIcon("Plugin1", "AutoPlay\\Icons\\Icon.ico");
   ToolBar.AddIcon("Plugin1", "AutoPlay\\Icons\\Icon2.ico");
   ToolBar.AddIcon("Plugin1", "AutoPlay\\Icons\\Icon3.ico");
   ToolBar.SetImageList("Plugin1");

end


ToolBar.AddSeparator

ToolBar.AddSeparator (

(string) ObjectName,

(number) Orientation )

Description

Adds a separator to a toolbar object.

Parameters

ObjectName

(string) The name of the object.

Orientation

(number) The orientation of separator.

CONSTANT | VALUE | DESCRIPTION
VERTICAL | 0 | A vertical Separator (Line between buttons)
HORIZONTAL | 1 | A horizontal Separator (Line between buttons)

Returns

This action dose not return any value.


ToolBar.AddIcon

(number) ToolBar.AddIcon (

(string) ObjectName,

(string) Icon )

Description

Adds an icon to a previously created image list.

Parameters

ObjectName

(string) The name of the object.

Icon

(string) The path to icon file.

Returns

(number) The zero based index of last added icon


ToolBar.SetVisible

ToolBar.SetVisible (

(string) ObjectName,

(boolean) Visible )

Description

Sets the visibility of a toolbar object.

Parameters

ObjectName

(string) The name of the object.

Visible

(boolean) Whether to make the toolbar object visible or invisible.

Returns

This action dose not return any value.


ToolBar.AddButton

ToolBar.AddButton (

(string) ObjectName,

(number) ButtonId,

(string) ToolTipText,

(string) Data,

(boolean) Marked,

(boolean) ToolTipVisible,

(number) NormalIcon,

(number) HighLightIcon,

(number) DownIcon )

Description

Adds a button to the toolbar object.

Parameters

ObjectName

(string) The name of the object.

ButtonId

(number) The id of the button for idendtification . This value shoud/must be a number

ToolTipText

(string) The tooltip text of button.

Data

(string) A multi purpose data field for button. Can hold any amount of string data.

Marked

(boolean) specifies the button is marked or not.

CONSTANT | VALUE | DESCRIPTION
true | NA | Button has a marker
false | NA | Button has no marker

ToolTipVisible

(boolean) specifies the visibility of button's tooltip.

CONSTANT | VALUE | DESCRIPTION
true | NA | Button has a tooltip
false | NA | Button has no tooltip

NormalIcon

(number) The icon index (zero based) for normal state of button.

HighLightIcon

(number) The icon index (zero based) for highlight state of button.

DownIcon

(number) The icon index (zero based) for down state of button.

Returns

This action dose not return any value.