ListBoxEx Plugin Help

PieChart Plugin

Welcome

PieChart Object Plugin Help File

Plugin Name :

PieChart

Current Version :

1.0.0.0

Last Update :

11/08/2009 (dd/mm/yyyy)

System Requirements :

Requires Win2000 Or Above

Additional Dependencies :

GdiPlus.dll

Licence :

Commercial

Author :

www.amsplugins.com

Web :

www.amsplugins.com

E-mail :

support@amsplugins.com

Copyright © 2009 www.amsplugins.com
All Rights Reserved.


ListBoxEx Plugin Help

PieChart Plugin

Properties

Properties

Background Color

Specifies the background color of PieChart object. you can select a color via color picker .

Border Style

Specifies the border style of PieChart object. you can select one of following None , Flat , Sunken ,Bevel .
None : no border
Flat : a thin-line border
Sunken : a border with a sunken edge
Bevel : a border with a raised edge

Pie Style

Specifies the pie chart style ,you can select one of following ThreeDStyle , TwoDStyle , DoughnuthStyle .
ThreeDStyle : three dimensional pie style
TwoDStyle : two dimensional pie style
DoughnuthStyle : doughnut pie style

Starting Angle

Specifies the starting angle of pie chart, you can set a value between 0 - 360

Incline Angle

Specifies the incline angle of pie chart (when it has 3D style ) , you can set a value between 0 - 90

3D Depth

Specifies the 3d depth of pie chart (when it has 3D style ) ,you can set a value between 0 - 100

Pie Distance

Specifies the distance of pie slices ,you can set a value between 0 - 100

Pie Transparency

Specifies the transparency of pie chart ,you can set a value between 0 - 100

Percentage Text

Specifies the percentage texts of pie chart are visible or not
True : percentage texts are visible
False : percentage texts are invisible

Show Legends

Specifies the visibility of pie chart legends
True : legends are visible
False : legends are invisible

HighLight Selection

Specifies the whether or not emphasize selected pie slice
True : highligt selection
False : do not highligt selection

Copyright © 2009 www.amsplugins.com


PieChart Plugin

Events

Events

OnCreate

Fires during object creation

OnLButtonDown

Fires when left mouse button down.

e_X:

(number) The X position of mouse.

e_Y:

(boolean) The Y position of mouse

OnLButtonUp

Fires when left mouse button relased.

e_X:

(number) The X position of mouse.

e_Y:

(boolean) The Y position of mouse

OnRButtonDown

Fires when right mouse button down.

e_X:

(number) The X position of mouse.

e_Y:

(boolean) The Y position of mouse

OnRButtonUp

Fires when right mouse button relased.

e_X:

(number) The X position of mouse.

e_Y:

(boolean) The Y position of mouse

OnMouseMove

Fires when user moves mouse over object.

e_X:

(number) The X position of mouse.

e_Y:

(boolean) The Y position of mouse

Copyright © 2009 www.amsplugins.com


PieChart Plugin

Update History

Update History Of PieChart Object Plugin

Verison : 1.0.0.0

  • Released At : 11/08/2009 (dd/mm/yyyy)

  • Inital Stable Release .

    • Copyright © 2009 www.amsplugins.com


Table-Of-Contents

Table of Contents

PieChart.SetSize
PieChart.GetSize
PieChart.GetPos
PieChart.SetPos
PieChart.IsEnabled
PieChart.SetEnabled
PieChart.IsVisible
PieChart.SetVisible
PieChart.Print
PieChart.SortToOrginalOrder
PieChart.Sort
PieChart.RemoveItem
PieChart.GetSliceLabel
PieChart.SetSliceLabel
PieChart.GetSliceValue
PieChart.SetSliceValue
PieChart.GetSliceColor
PieChart.SetSliceColor
PieChart.GetShowLegends
PieChart.SetShowLegends
PieChart.GetSelectedSlice
PieChart.SetTitleFont
PieChart.SetLabelFont
PieChart.SaveToFile
PieChart.SetSliceDistance
PieChart.SetDistanceAll
PieChart.SetSliceTransparency
PieChart.SetTransparencyAll
PieChart.SetDepth
PieChart.SetBackgrndColor
PieChart.SetInclineAngle
PieChart.SetStartAngle
PieChart.ShowPercentagesOnPie
PieChart.SetChartStyle
PieChart.SetTitle
PieChart.InsertItem

Copyright © 2008 - 2009 www.amsplugins.com


PieChart.SortToOrginalOrder

PieChart.SortToOrginalOrder (

(string) ObjectName )

Description

Sorts the pie chart slices to orginal order if you sort them before ( undoes any sort operation made before)

Parameters

ObjectName

(string) The name of the object.

Returns

This action dose not return any value.


PieChart.Sort

PieChart.Sort (

(string) ObjectName,

(boolean) ClockWise )

Description

Sorts the pie chart slices

Parameters

ObjectName

(string) The name of the object.

ClockWise

(boolean) sort by clockwise.

Returns

This action dose not return any value.


PieChart.ShowPercentagesOnPie

PieChart.ShowPercentagesOnPie (

(string) ObjectName,

(boolean) Visible )

Description

Shows or hides percentage texts on pie

Parameters

ObjectName

(string) The name of the object.

Visible

(boolean) The visibility of percentage texts of pie chart.

Returns

This action dose not return any value.


PieChart.SetVisible

PieChart.SetVisible (

(string) ObjectName,

(boolean) Visible )

Description

Sets the visibility of a PieChart object.

Parameters

ObjectName

(string) The name of the object.

Visible

(boolean) Whether to make the PieChart object visible or invisible.

Returns

This action dose not return any value.


PieChart.SetTransparencyAll

PieChart.SetTransparencyAll (

(string) ObjectName,

(number) Transparency )

Description

Sets the transparency of whole pie

Parameters

ObjectName

(string) The name of the object.

Transparency

(number) The tranparency value (0 - 100).

Returns

This action dose not return any value.


PieChart.SetTitleFont

PieChart.SetTitleFont (

(string) ObjectName,

(string) Font Name,

(number) Font Weight,

(boolean) Italic,

(boolean) Underlie,

(boolean) StrikeOut )

Description

Sets the font of the pie chart title.

Parameters

ObjectName

(string) The name of the object.

Font Name

(string) Identifies the Font Name

Font Weight

(number) Identifies the Font weight

Italic

(boolean) Identifies the italic Font or not

Underlie

(boolean) Identifies the underline Font or not

StrikeOut

(boolean) Identifies the strikeout Font or not

Returns

This action dose not return any value.


PieChart.SetTitle

PieChart.SetTitle (

(string) ObjectName,

(string) Title )

Description

Sets the title of a pie chart object

Parameters

ObjectName

(string) The name of the object.

Title

(string) The title of pie chart object.

Returns

This action dose not return any value.


PieChart.SetStartAngle

PieChart.SetStartAngle (

(string) ObjectName,

(number) Angle )

Description

Sets the starting angle of pie chart

Parameters

ObjectName

(string) The name of the object.

Angle

(number) The starting angle (0 - 360) . By default the starting angle is (0)zero

Returns

This action dose not return any value.


PieChart.SetSliceValue

(boolean) PieChart.SetSliceValue (

(string) ObjectName,

(string) ID,

(number) Value )

Description

Sets the value of a pie chart slice

Parameters

ObjectName

(string) The name of the object.

ID

(string) The ID of slice.

Value

(number) The percent value of slice. The maximum value is 100.00 , also this value can be a float like: 12.50

Returns

(boolean) Returns true on succeded and returns false on failed


PieChart.SetSliceTransparency

(boolean) PieChart.SetSliceTransparency (

(string) ObjectName,

(string) ID,

(number) Transparency )

Description

Sets the transparency of a pie slice

Parameters

ObjectName

(string) The name of the object.

ID

(string) The ID of slice.

Transparency

(number) The tranparency value (0 - 100).

Returns

(boolean) Returns true on succeded and returns false on failed


PieChart.SetSliceLabel

(boolean) PieChart.SetSliceLabel (

(string) ObjectName,

(string) ID,

(string) Label )

Description

Sets the label text of a pie chart slice

Parameters

ObjectName

(string) The name of the object.

ID

(string) The ID of slice.

Label

(string) The label text of slice.

Returns

(boolean) Returns true on succeded and returns false on failed


PieChart.SetSliceDistance

(boolean) PieChart.SetSliceDistance (

(string) ObjectName,

(string) ID,

(number) Distance )

Description

Sets the distance of a pie slice

Parameters

ObjectName

(string) The name of the object.

ID

(string) The ID of slice.

Distance

(number) The distance value (0 - 100).

Returns

(boolean) Returns true on succeded and returns false on failed


PieChart.SetSliceColor

(boolean) PieChart.SetSliceColor (

(string) ObjectName,

(string) ID,

(number) Color )

Description

Sets the color of a pie chart slice

Parameters

ObjectName

(string) The name of the object.

ID

(string) The ID of slice.

Color

(number) The color value of slice.

Returns

(boolean) Returns true on succeded and returns false on failed


PieChart.SetSize

PieChart.SetSize (

(string) ObjectName,

(number) Width,

(number) Height )

Description

Sets the size of a PieChart object.

Parameters

ObjectName

(string) The name of the object.

Width

(number) The new width of object.

Height

(number) The new height of object .

Returns

This action dose not return any value.


PieChart.SetShowLegends

PieChart.SetShowLegends (

(string) ObjectName,

(boolean) Visible )

Description

Shows or hides the legends of pie chart

Parameters

ObjectName

(string) The name of the object.

Visible

(boolean) The visibility of of pie chart legends.

Returns

This action dose not return any value.


PieChart.SetPos

PieChart.SetPos (

(string) ObjectName,

(number) X,

(number) Y )

Description

Sets the position of a PieChart object.

Parameters

ObjectName

(string) The name of the object.

X

(number) The new X position of object.

Y

(number) The new Y position of object .

Returns

This action dose not return any value.


PieChart.SetLabelFont

PieChart.SetLabelFont (

(string) ObjectName,

(string) Font Name,

(number) Font Weight,

(boolean) Italic,

(boolean) Underlie,

(boolean) StrikeOut )

Description

Sets the font of all Labels.

Parameters

ObjectName

(string) The name of the object.

Font Name

(string) Identifies the Font Name

Font Weight

(number) Identifies the Font weight

Italic

(boolean) Identifies the italic Font or not

Underlie

(boolean) Identifies the underline Font or not

StrikeOut

(boolean) Identifies the strikeout Font or not

Returns

This action dose not return any value.


PieChart.SetInclineAngle

PieChart.SetInclineAngle (

(string) ObjectName,

(number) Angle )

Description

Sets the incline drawing angle of pie chart

Parameters

ObjectName

(string) The name of the object.

Angle

(number) The incline angle (0 - 90) . By default the incline angle is (0)zero

Returns

This action dose not return any value.


PieChart.SetEnabled

PieChart.SetEnabled (

(string) ObjectName,

(boolean) Enable )

Description

Sets the enabled/disabled state of a PieChart object.

Parameters

ObjectName

(string) The name of the object.

Enable

(boolean) Whether to make the PieChart object enabled or disabled.

Returns

This action dose not return any value.


PieChart.SetDistanceAll

PieChart.SetDistanceAll (

(string) ObjectName,

(number) Distance )

Description

Sets the distance of all pie slices

Parameters

ObjectName

(string) The name of the object.

Distance

(number) The distance value (0 - 100).

Returns

This action dose not return any value.


PieChart.SetDepth

PieChart.SetDepth (

(string) ObjectName,

(number) Angle )

Description

Sets the depth of pie when it has 3D style

Parameters

ObjectName

(string) The name of the object.

Angle

(number) The depth value (0 - 100).

Returns

This action dose not return any value.


PieChart.SetChartStyle

PieChart.SetChartStyle (

(string) ObjectName,

(number) Style )

Description

Sets the drawing style of a pie chart object

Parameters

ObjectName

(string) The name of the object.

Style

(number) The style of the pie.

CONSTANT | VALUE | DESCRIPTION
CHARTSTYLE_3D | 2 | Three Dimensional Pie Style
CHARTSTYLE_2D | 1 | Two Dimensional Pie Style
CHARTSTYLE_DOUGHNUT | 0 | Doughnut Pie Style

Returns

This action dose not return any value.


PieChart.SetBackgrndColor

PieChart.SetBackgrndColor (

(string) ObjectName,

(number) Backcolor )

Description

Sets the background color of a pie chart object

Parameters

ObjectName

(string) The name of the object.

Backcolor

(number) The background color

Returns

This action dose not return any value.


PieChart.SaveToFile

(boolean) PieChart.SaveToFile (

(string) ObjectName,

(string) Image )

Description

Saves current view in to a image file

Parameters

ObjectName

(string) The name of the object.

Image

(string) The path to a image file. File format depends on the file extension you sipecified (accepted formats are: gif , jpg , png)

Returns

(boolean) Returns true on succeded and returns false on failed


PieChart.RemoveItem

(boolean) PieChart.RemoveItem (

(string) ObjectName,

(string) ID )

Description

Removes an item (slice) from pie chart

Parameters

ObjectName

(string) The name of the object.

ID

(string) The ID of item.

Returns

(boolean) Returns true on succeded and returns false on failed


PieChart.Print

PieChart.Print (

(string) ObjectName )

Description

Prints the current view of pie chart

Parameters

ObjectName

(string) The name of the object.

Returns

This action dose not return any value.


PieChart.IsVisible

(boolean) PieChart.IsVisible (

(string) ObjectName )

Description

Retruns true if specified PieChart object is visible. and false if it is not.

Parameters

ObjectName

(string) The name of the object.

Returns

(boolean) Retruns true if specified PieChart object is visible. and false if it is not.


PieChart.IsEnabled

(boolean) PieChart.IsEnabled (

(string) ObjectName )

Description

Retruns true is specified PieChart object is enabled. and false if it is disabled.

Parameters

ObjectName

(string) The name of the object.

Returns

(boolean) Retruns true is specified PieChart object is enabled. and false if it is disabled.


PieChart.InsertItem

(boolean) PieChart.InsertItem (

(string) ObjectName,

(string) ID,

(string) Label,

(number) Value,

(number) Color )

Description

Inserts a slice to pie chart object. Note: first slice always gets %100 unless you add new slices

Parameters

ObjectName

(string) The name of the object.

ID

(string) The ID of slice.

Label

(string) The label text of slice.

Value

(number) The percent value of slice. The maximum value is 100.00 , also this value can be a float like: 12.50

Color

(number) The color value of slice.

Returns

(boolean) Returns true on succeded and returns false on failed


PieChart.GetSliceValue

(number) PieChart.GetSliceValue (

(string) ObjectName,

(string) ID )

Description

Gets the value of a pie chart slice

Parameters

ObjectName

(string) The name of the object.

ID

(string) The ID of slice.

Returns

(number) Returns the specified slice's decimal value , if an error occurs the return value is -1


PieChart.GetSliceLabel

(string) PieChart.GetSliceLabel (

(string) ObjectName,

(string) ID )

Description

Gets the label text of a pie chart slice

Parameters

ObjectName

(string) The name of the object.

ID

(string) The ID of slice.

Returns

(string) Returns the label text of specified slice , if an error occurs the return value is a empty string ""


PieChart.GetSliceColor

(number) PieChart.GetSliceColor (

(string) ObjectName,

(string) ID )

Description

Gets the color of a pie chart slice

Parameters

ObjectName

(string) The name of the object.

ID

(string) The ID of slice.

Returns

(number) Returns decimal color value of specified slice , if an error occurs the return value is -1


PieChart.GetSize

(table) PieChart.GetSize (

(string) ObjectName )

Description

Gets the size of a PieChart object.

Parameters

ObjectName

(string) The name of the object.

Returns

(table) returns a table containing object dimensions
table indexes are : Width and Height
returs nil if an error occurs


PieChart.GetShowLegends

(boolean)PieChart.GetShowLegends (

(string) ObjectName )

Description

Gets the visibility of pie chart legends

Parameters

ObjectName

(string) The name of the object.

Returns

(boolean) Returns true if legends are visible and returns false legends are invisible


PieChart.GetSelectedSlice

(string) PieChart.GetSelectedSlice (

(string) ObjectName )

Description

Returns the ID of currently selected pie slice if it was set , Returns nil if no slice selected

Parameters

ObjectName

(string) The name of the object.

Returns

(string) Returns the ID of currently selected pie slice if it was set , Returns nil if no slice selected


PieChart.GetPos

(table) PieChart.GetPos (

(string) ObjectName )

Description

Gets the position of a PieChart object.

Parameters

ObjectName

(string) The name of the object.

Returns

(table) returns a table containing object position
table indexes are : X and Y
returs nil if an error occurs


PieChart Help File

Welcome

PieChart Help File

Plugin Name:

PieChart

Current Version:

...