PDF Plugin Help

PDF Plugin

Welcome

PDF Object Plugin Help File

Plugin Name :

PDF

Current Version :

2.2.0.0

Last Update :

13/06/2009 (dd/mm/yyyy)

System Requirements :

Requires Win98 Or Above

Additional Dependencies :

Adobe Reader ver: 6 Or Above

Licence :

Freeware

Author :

Reteset

Web :

www.amsplugins.com

E-mail :

support@amsplugins.com

Copyright :

The PDF plugin is copyright © 2008 -2009 www.amsplugins.com

Copyright © 2008 Reteset.
All Rights Reserved.


Events

Events

On Click

Fires when the mouse clicks on the object.

On Enter

Fires when the mouse enters the object.

On Leave

Fires when the mouse leaves the object.


Properties

Properties

Border Style

Specifies the border style of PDF object. you can select one of following None , Flat , Sunken .
None : no border
Flat : a thin-line border
Sunken : a border with a sunken edge

ToolBar

Specifies the toolbar visible or invisible , set Yes for visible toolbar No for invisible toolbar.


PDF.ForwardStack()

PDF.ForwardStack (string ObjectName);

Description:

Goes to the next view on the view stack, if the next view exists. The next view may be in a different document.

ObjectName:

(string) The name of the object that you want to apply this action to.

Returns:

Nothing.

Example:

PDF.ForwardStack("Plugin1");


PDF.BackwardStack()

PDF.BackwardStack (string ObjectName);

Description:

Goes to the previous view on the view stack, if the previous view exists. The previous view may be in a different document.

ObjectName:

(string) The name of the object that you want to apply this action to.

Returns:

Nothing.

Example:

PDF.BackwardStack("Plugin1");


PDF.GotoNamedDest()

PDF.GotoNamedDest(string ObjectName,string Destination);

Description:

Changes the page view to the named destination in the specified string.

ObjectName:

(string) The name of the object that you want to apply this action to.

Destination:

(string)The named destination to which the viewer will go.

Returns:

Nothing

Example:

PDF.GotoNamedDest("Plugin1","Product-Details");


PDF.SetCurrentPage()

PDF.SetCurrentPage (string ObjectName,number Page);

Description:

Sets Current Page Of A PDF Document

ObjectName:

(string) The name of the object that you want to apply this action to.

Page:

(number) the page number

Returns:

Nothing.

Example:

PDF.SetCurrentPage("Plugin1",1);


PDF.GotoPreviousPage()

PDF.GotoPreviousPage (string ObjectName);

Description:

Goes to the previous page in the document, if it exists. Maintains the current location within the page and zoom level.

ObjectName:

(string) The name of the object that you want to apply this action to.

Returns:

Nothing.

Example:

PDF.GotoPreviousPage("Plugin1");


PDF.GotoNextPage()

PDF.GotoNextPage (string ObjectName);

Description:

Goes to the next page in the document, if it exists. Maintains the current location within the page and zoom level.

ObjectName:

(string) The name of the object that you want to apply this action to.

Returns:

Nothing.

Example:

PDF.GotoNextPage("Plugin1");


PDF.GotoLastPage()

PDF.GotoLastPage (string ObjectName);

Description:

Goes to the last page in the document, maintaining the current location within the page and zoom level.

ObjectName:

(string) The name of the object that you want to apply this action to.

Returns:

Nothing.

Example:

PDF.GotoLastPage("Plugin1");


PDF.GotoFirstPage()

PDF.GotoFirstPage (string ObjectName);

Description:

Goes to the first page in the document, maintaining the current location within the page and zoom level.

ObjectName:

(string) The name of the object that you want to apply this action to.

Returns:

Nothing.

Example:

PDF.GotoFirstPage("Plugin1");


PDF.ShowToolBar()

PDF.ShowToolBar (string ObjectName,boolean Visible);

Description:

Shows Or Hides The ToolBar Of A PDF Object

ObjectName:

(string) The name of the object that you want to apply this action to.

Visible:

(boolean) Visibility Flag

Returns:

Nothing.

Example:

--show toolbar
PDF.ShowToolBar("Plugin1",true);

--hide toolbar
PDF.ShowToolBar("Plugin1",false);


PDF.ShowScrollBars()

PDF.ShowScrollBars (string ObjectName,boolean Visible);

Description:

Shows Or Hides The ScrollBars Of A PDF Object

ObjectName:

(string) The name of the object that you want to apply this action to.

Visible:

(boolean) Visibility Flag

Returns:

Nothing.

Example:

--show scrollbars
PDF.ShowScrollBars("Plugin1",true);

--hide scrollbars
PDF.ShowScrollBars("Plugin1",false);


PDF.SetLayoutMode()

PDF.SetLayoutMode(string ObjectName,string Mode);

Description:

Sets the layout mode for a page view according to the specified string.

ObjectName:

(string) The name of the object that you want to apply this action to.

Mode:

(string)New Layout Mode

Possible values:
"DontCare" : use the current user preference
"SinglePage" : use single page mode (as it would have appeared in pre-Acrobat 3.0 viewers)
"OneColumn" : use one-column continuous mode
"TwoColumnLeft" : use two-column continuous mode with the first page on the left
"TwoColumnRight" : use two-column continuous mode with the first page on the right

Returns:

Nothing

Example:

PDF.SetLayoutMode("Plugin1","DontCare");


PDF.SetView()

PDF.SetView(string ObjectName,string Mode);

Description:

Sets the view of a page according to the specified string

ObjectName:

(string) The name of the object that you want to apply this action to.

Mode:

(string)New View Mode

Possible values:
"Fit" : fits the entire page within the window both vertically and horizontally.
"FitH" : fits the entire width of the page within the window.
"FitV" : fits the entire height of the page within the window.
"FitB" : fits the bounding box within the window both vertically and horizontally.
"FitBH" : fits the entire width of the bounding box within the window.
"FitBV" : fits the entire height of the bounding box within the window.

Returns:

Nothing

Example:

PDF.SetView("Plugin1","FitBH");


PDF.SetZoom()

PDF.SetZoom (string ObjectName,number Percent);

Description:

Sets the magnification according to the specified value

ObjectName:

(string) The name of the object that you want to apply this action to.

Percent:

(number) The desired zoom factor, expressed as a percentage

this argument should be between 25 - 300

Returns:

Nothing.

Example:

PDF.SetZoom("Plugin1",100);


PDF.SetPageMode()

PDF.SetPageMode(string ObjectName,string Mode);

Description:

Sets Page Mode Of A PDF Object

ObjectName:

(string) The name of the object that you want to apply this action to.

Mode:

(string)New Page Mode

Possible values:
"none" : displays the document, but does not display bookmarks or thumbnails (default)
"bookmarks" : displays the document and bookmarks
"thumbs" : displays the document and thumbnails

Returns:

Nothing

Example:

PDF.SetPageMode("Plugin1","bookmarks");


PDF.LoadFromWeb()

PDF.LoadFromWeb (string ObjectName,string Url);

Description:

Loads A PDF Document In To PDF Object From Web

ObjectName:

(string) The name of the object that you want to apply this action to.

Url:

(string)A Valid File Url For PDF Document

Returns:

returns nothing

Example:

PDF.LoadFromWeb("Plugin1", "http://sample.com/sample.pdf");


PDF.SafeExit()

PDF.SafeExit (string ObjectName);

Description:

Destroys PDF object with safe .This action should be called on application exit ( 'On Close' event is a good place for this action )

NOTE:If active page contains more than one object this action should be added for each object.

ObjectName:

(string) The name of the object that you want to apply this action to.

Returns:

Nothing.

Example:

PDF.SafeExit("Plugin1");


PDF.LoadFile()

boolean PDF.LoadFile (string ObjectName,string Path);

Description:

Loads A PDF Document In To PDF Object

Note : When this function called object will reset all appearace settings except toolbar
toolbar remains with old state but all of others will be changed to default settings or document specific settings
if you want to one style while browsing PDF documents you should re-apply all of your adjustments after each call of this function

ObjectName:

(string) The name of the object that you want to apply this action to.

Path:

(string)A Valid File Path For PDF Document

Returns:

returns true on succeed ,false otherwise

Example:

PDF.LoadFile("Plugin1","C:\\myPdfManual.pdf");


PDF.Print()

PDF.Print (string ObjectName);

Description:

Prints the document according to the options selected in a user dialog box.

NOTE:If security settings do not allow printing, this method will be ignored.

ObjectName:

(string) The name of the object that you want to apply this action to.

Returns:

Nothing.

Example:

PDF.Print("Plugin1");


PDF.GetSRC()

string PDF.GetSRC (string ObjectName);

Description:

Returns Path Of Currently Loaded PDF Document

ObjectName:

(string) The name of the object that you want to apply this action to.

Returns:

on succeed : returns path of current document
on failure : returns an empty string ""

Example:

currentFile = PDF.GetSRC("Plugin1");