ListBoxEx Plugin Help

ImageScroller Plugin

Welcome

ImageScroller Object Plugin Help File

Plugin Name :

ImageScroller

Current Version :

1.0.0.0

Last Update :

22/09/2009 (dd/mm/yyyy)

System Requirements :

Requires Win2000 Or Above

Additional Dependencies :

None

Licence :

Commercial

Author :

www.amsplugins.com

Web :

www.amsplugins.com

E-mail :

support@amsplugins.com

Copyright :

The ImageScroller plugin is copyright © 2008 - 2009 www.amsplugins.com

Credits :

AMS ActionFile Editor Is Mostly Used On Creation Of This Help File

Copyright © 2008 - 2009 www.amsplugins.com
All Rights Reserved.


ListBoxEx Plugin Help

ImageScroller Plugin

Properties

Properties

BackGround Color

Specifies the background color of ImageScroller object. you can select a color via color picker .

Border Style

Specifies the border style of ImageScroller object. you can select one of following None , Flat , Sunken ,Bevel .
None : no border
Flat : a thin-line border
Sunken : a border with a sunken edge
Bevel : a border with a raised edge


ListBoxEx Plugin

Events

Events

On Create

Fires during object creation

On Enter

Fires when the mouse enters the object.

On Leave

Fires when the mouse leaves the object.

OnLButtonDown

Fires when left mouse button down

e_X:

(number) The X position of mouse.

e_Y:

(number) The Y position of mouse

OnLButtonUp

Fires when left mouse button up

e_X:

(number) The X position of mouse.

e_Y:

(number) The Y position of mouse

OnLButtonDblClick

Fires when left mouse button double clicked

e_X:

(number) The X position of mouse.

e_Y:

(number) The Y position of mouse

OnRButtonDown

Fires when right mouse button down

e_X:

(number) The X position of mouse.

e_Y:

(number) The Y position of mouse

OnRButtonUp

Fires when right mouse button up

e_X:

(number) The X position of mouse.

e_Y:

(number) The Y position of mouse

OnMouseMove

Fires when user moves mouse over object

e_X:

(number) The X position of mouse.

e_Y:

(number) The Y position of mouse

OnMBLeftClick

Fires when the user left clicks to message-bar of ImageScroller

OnMBRightClick

Fires when the user right clicks to message-bar of ImageScroller

On DopFiles

Fires when user drops Files/Folders over ImageScroller object , if drag and drop is enabled.

e_Count:

(number) The number of items dropped by user (Always more than 0 (zero)) .

OnDownloadProgress

Fires when an image download is in progress

e_Total:

(number) The total size of image file that is currenly downloading . (in bytes)

e_Current:

(number) The download size of image (in bytes)

Copyright © 2008 Reteset.


ImageScroller Plugin

Update History

Update History Of ImageScroller Object Plugin

Verison : 1.0.0.0

  • Released At : 22/09/2009 (dd/mm/yyyy)

  • Inital Release .

    • Copyright © 2008 - 2009 www.amsplugins.com


ImageScroller.SetVisible

ImageScroller.SetVisible (

(string) ObjectName,

(boolean) Visible )

Description

Sets the visibility of a ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

Visible

(boolean) Whether to make the ImageScroller object visible or invisible.

Returns

This action dose not return any value.


ImageScroller.SetSize

ImageScroller.SetSize (

(string) ObjectName,

(number) Width,

(number) Height )

Description

Sets the size of a ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

Width

(number) The new width of object.

Height

(number) The new height of object .

Returns

This action dose not return any value.


ImageScroller.SetPos

ImageScroller.SetPos (

(string) ObjectName,

(number) X,

(number) Y )

Description

Sets the position of a ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

X

(number) The new X position of object.

Y

(number) The new Y position of object .

Returns

This action dose not return any value.


ImageScroller.SetEnabled

ImageScroller.SetEnabled (

(string) ObjectName,

(boolean) Enable )

Description

Sets the enabled/disabled state of a ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

Enable

(boolean) Whether to make the ImageScroller object enabled or disabled.

Returns

This action dose not return any value.


ImageScroller.SetCursor

(boolean) ImageScroller.SetCursor (

(string) ObjectName,

(string) Cursor )

Description

Sets the cursor of a ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

Cursor

(string) The path to cursor file (leave blank for restore to default cursor).

Returns

(boolean) retruns true if succeeded. and false if failed


ImageScroller.SetAcceptFiles

ImageScroller.SetAcceptFiles (

(string) ObjectName,

(boolean) Enable )

Description

Enables or disables whether ImageScroller accepts dropped files.

Parameters

ObjectName

(string) The name of the object.

Enable

(boolean) The state of whether ImageScroller accepts dropped files

Returns

This action dose not return any value.


ImageScroller.MessageBarShow

(boolean) ImageScroller.MessageBarShow (

(string) ObjectName,

(string) Text,

(number) IconID,

(boolean) CloseButton,

(boolean) WrapText )

Description

Shows a message bar at the top of a ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

Text

(string) The message text.

IconID

(number) The message type icon.

CONSTANT | VALUE | DESCRIPTION
IS_ICONNONE | -1 | No Icon
IS_ICONSTOP | 0 | Icon Stop
IS_ICONQUESTION | 1 | Icon Question
IS_ICONEXCLAMATION | 2 | Icon Exclamation
IS_ICONINFORMATION | 3 | Icon Information

CloseButton

(boolean) if true close button visible , if false close button invisible.

WrapText

(boolean) if true message bar will be resized vertically as text needs , if false long text will be truncated .

Returns

(boolean) retruns true if succeeded. and false if failed


ImageScroller.MessageBarSetColors

ImageScroller.MessageBarSetColors (

(string) ObjectName,

(number) Back,

(number) BackHilite,

(number) Text,

(number) TextHilite )

Description

Sets message bar colors of a ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

Back

(number) The background color of messagebar .

BackHilite

(number) The background highlight color of message bar .

Text

(number) The text color of message bar.

TextHilite

(number) The text highlight color of message bar .

Returns

This action dose not return any value.


ImageScroller.MessageBarIsVisible

(boolean) ImageScroller.MessageBarIsVisible (

(string) ObjectName )

Description

Determines whether message bar is visible or not

Parameters

ObjectName

(string) The name of the object.

Returns

(boolean) retruns true if message bar is visible. and false if it is invisible


ImageScroller.MessageBarHide

ImageScroller.MessageBarHide (

(string) ObjectName )

Description

Hides a message bar at the top of a ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

Returns

This action dose not return any value.


ImageScroller.LoadResource

(number) ImageScroller.LoadResource (

(string) ObjectName,

(string) Resource,

(variant) ResourceID,

(variant) ResourceType )

Description

Loads a image from a executable to a ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

Resource

(string) The path to a executable file.( e.g : exe , dll , ocx)

ResourceID

(variant) The ordinal (number) or name (string) of image in resource file

ResourceType

(variant) The type specifier of resource (string or number)

Returns

(boolean) retruns true if succeeded. and false if failed

Example:

RT_BITMAP = 2;

bbbrRet = ImageScroller.LoadResource("Plugin1", _SystemFolder.."\\Shell32.dll", 131, RT_BITMAP);

 if not ( bbbrRet ) then

      Dialog.Message("Notice", "Failed To Load Image From Resource", MB_OK, MB_ICONINFORMATION, MB_DEFBUTTON1);

 end


ImageScroller.LoadFromWeb

(boolean) ImageScroller.LoadFromWeb (

(string) ObjectName,

(string) ImageUrl )

Description

Loads a image to ImageScroller object from a remote web server.

Parameters

ObjectName

(string) The name of the object.

ImageUrl

(string) The Url to a image file on a remote web server

Acccepted formats : BMP, JPEG, GIF(single frame), PNG, TIFF(single frame), MNG, ICO, PCX, TGA

Returns

(boolean) retruns true if succeeded. and false if failed

Example:

 bRetWeb = ImageScroller.LoadFromWeb("Plugin1", "http://www.domain.com/test.jpg");

   if not ( bRetWeb ) then

    Dialog.Message("Notice", "Failed To Load Image From Remote Server.", MB_OK, MB_ICONINFORMATION, MB_DEFBUTTON1);

    end


ImageScroller.LoadBinary

(boolean) ImageScroller.LoadBinary (

(string) ObjectName,

(string) Data )

Description

Loads a image to ImageScroller object in binary data form .

Parameters

ObjectName

(string) The name of the object.

Data

(string) The binary data of a image

Acccepted formats : BMP, JPEG, GIF(single frame), PNG, TIFF(single frame), MNG, ICO, PCX, TGA

Returns

(boolean) retruns true if succeeded. and false if failed

Example:

 local f = assert(io.open(image_file,"rb"))
 local bytes = f:read("*all")

 if  (bytes ~= nil) then end

bbRet = ImageScroller.LoadBinary("Plugin1", bytes);

 if not ( bbRet ) then

      Dialog.Message("Notice", "Failed To Load Binary Data", MB_OK, MB_ICONINFORMATION, MB_DEFBUTTON1);

   end

 f:close();


ImageScroller.LoadBase64

(boolean) ImageScroller.LoadBase64 (

(string) ObjectName,

(string) Data )

Description

Loads a image to ImageScroller object in base64 encoded data form .

Parameters

ObjectName

(string) The name of the object.

Data

(string) The base64 encoded data of a image

Acccepted formats : BMP, JPEG, GIF(single frame), PNG, TIFF(single frame), MNG, ICO, PCX, TGA

Returns

(boolean) retruns true if succeeded. and false if failed

Example:

base64_string = Crypto.Base64EncodeToString(image_file, 76);

bbbRet = ImageScroller.LoadBase64("Plugin1", base64_string);

   if not ( bbbRet ) then

      Dialog.Message("Notice", "Failed To Load Base64 Encoded Data", MB_OK, MB_ICONINFORMATION, MB_DEFBUTTON1);

   end


ImageScroller.Load

(boolean) ImageScroller.Load (

(string) ObjectName,

(string) Image )

Description

Loads a image to ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

Image

(string) The (Full) path to a image file ,

Acccepted formats : BMP, JPEG, GIF(single frame), PNG, TIFF(single frame), MNG, ICO, PCX, TGA

Returns

(boolean) retruns true if succeeded. and false if failed

Example:

tblImage = Dialog.FileBrowse(true, "Locate Image File", _DesktopFolder, "All Files (*.*)|*.*|", "", "", false, true);

  if (tblImage) then

    if (tblImage[1] ~= "CANCEL") then

         bRet = ImageScroller.Load("Plugin1", tblImage[1]);

         if not ( bRet ) then

          Dialog.Message("Notice", "Failed To Load This File :\r\n"..tblImage[1], MB_OK, MB_ICONINFORMATION, MB_DEFBUTTON1);

         end

    end

 end


ImageScroller.IsVisible

(boolean) ImageScroller.IsVisible (

(string) ObjectName )

Description

Retruns true is specified ImageScroller object is visible. and false if it is not.

Parameters

ObjectName

(string) The name of the object.

Returns

(boolean) Retruns true is specified ImageScroller object is visible. and false if it is not.


ImageScroller.IsEnabled

(boolean) ImageScroller.IsEnabled (

(string) ObjectName )

Description

Retruns true is specified ImageScroller object is enabled. and false if it is disabled.

Parameters

ObjectName

(string) The name of the object.

Returns

(boolean) Retruns true is specified ImageScroller object is enabled. and false if it is disabled.


ImageScroller.GetSize

(table) ImageScroller.GetSize (

(string) ObjectName )

Description

Gets the size of a ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

Returns

(table) returns a table containing object dimensions
table indexes are : Width and Height
returs nil if an error occurs


ImageScroller.GetPos

(table) ImageScroller.GetPos (

(string) ObjectName )

Description

Gets the position of a ImageScroller object.

Parameters

ObjectName

(string) The name of the object.

Returns

(table) returns a table containing object position
table indexes are : X and Y
returs nil if an error occurs


ImageScroller.GetDroppedFiles

(table) ImageScroller.GetDroppedFiles (

(string) ObjectName,

(boolean) Clean )

Description

Returns a numerically indexed table that contains the dropped file/folder paths.

Parameters

ObjectName

(string) The name of the object.

Clean

(boolean) if true this action cleans dropped file list in memory, if false dropped file list stays in memory until next drag and drop operation

Returns

(table) returns a numerically indexed table containing file/forlder paths that dropped by user
returns nil if there is no list available ,or list removed by previous call of this action

Example:

tblDropList = ImageScroller.GetDroppedFiles("Plugin1", true);

if (tblDropList ~= nil ) then

      local bRet = ImageScroller.Load("Plugin1", tblDropList[1]);

         if not ( bRet ) then

              Dialog.Message("Notice", "Failed To Load : "..tblDropList[1], MB_OK, MB_ICONINFORMATION, MB_DEFBUTTON1);

         end

end


ImageScroller.GetAcceptFiles

(boolean) ImageScroller.GetAcceptFiles (

(string) ObjectName )

Description

Gets the state of whether ImageScroller accepts dropped files.

Parameters

ObjectName

(string) The name of the object.

Returns

(boolean) retruns true if ImageScroller Accepts files/Folders. and false if it is not