Slider Plugin Help

Gradient Plugin

Welcome

Gradient Object Plugin Help File

Plugin Name :

Gradient

Current Version :

1.1.0.0

Last Update :

11/05/2008 (dd/mm/yyyy)

System Requirements :

Requires Win98 Or Above

Licence :

Special Build (Commercial)
Note : You Should have a Licence For Use This Plugin
This Plugin Is Free For VIP Members

Special Offer:

You Can Get Full Version Of This Plugin For Free Via Donating Minimum 10 USD

Author :

Reteset reteset@hotmail.com

Copyright :

The Gradient plugin is copyright © 2008 Reteset.

Copyright © 2008 Reteset.
All Rights Reserved.


Gradient Plugin Help

Gradient Plugin

Events

Events

On Click

Fires when the mouse clicks on the shape.

On Enter

Fires when the mouse enters the shape.

On Leave

Fires when the mouse leaves the shape.


Slider Plugin Help

Gradient Plugin

Properties

Properties

Orientation

Specifies the orientation of gradient. you can select one of following
HORIZONTAL = Horizontal Orientation
VERTICAL = Vertical Orientation
F_DIAGONAL = Forward Diagonal Orientation
B_DIAGONAL = Backward Diagonal Orientation
NONE = No Fill

Colors Used

Specifies the number of colors will be used. you can select minimum = 2 maximum = 11.

Border

Specifies the border style of gradient. you can select one of following Yes , No .
Yes : Shape Has A Border
No : Shape Has No A Border

Border Width

Specifies the border width. you can select minimum = 1 maximum = 10.

Border Color

Specifies the border color. you can select a color via color picker .

Color 1

Specifies the color 1 for gradient. you can select a color via color picker .

Color 2

Specifies the color 2 for gradient. you can select a color via color picker .

Color 3

Specifies the color 3 for gradient. you can select a color via color picker .

Color 4

Specifies the color 4 for gradient. you can select a color via color picker .

Color 5

Specifies the color 5 for gradient. you can select a color via color picker .

Color 6

Specifies the color 6 for gradient. you can select a color via color picker .

Color 7

Specifies the color 7 for gradient. you can select a color via color picker .

Color 8

Specifies the color 8 for gradient. you can select a color via color picker .

Color 9

Specifies the color 9 for gradient. you can select a color via color picker .

Color 10

Specifies the color 10 for gradient. you can select a color via color picker .

Color 11

Specifies the color 11 for gradient. you can select a color via color picker .


Gradient Plugin

Gradient.SetColorSchema()

Gradient.SetColorSchema (string ObjectName,number ColorsUsed,number Color1 . . . number Color11);

Description:

Changes the shape's color schema

ObjectName:

(string) The name of the object that you want to apply this action to.

ColorUsed:

(number)Specifies the number of colors in use this value can be Min = 2 or Max = 11
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Color1:

(number)Specifies the color 1 for gradient. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Color2:

(number)Specifies the color 2 for gradient. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Color3:

(number)Specifies the color 3 for gradient. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Color4:

(number)Specifies the color 4 for gradient. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Color5:

(number)Specifies the color 5 for gradient. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Color6:

(number)Specifies the color 6 for gradient. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Color7:

(number)Specifies the color 7 for gradient. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Color8:

(number)Specifies the color 8 for gradient. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Color9:

(number)Specifies the color 9 for gradient. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Color10:

(number)Specifies the color 10 for gradient. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Color11:

(number)Specifies the color 11 for gradient. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Returns:

Nothing.

Example 1:

-- change only first 3 colors
-- and do not touch all of others
Gradient.SetColorSchema("Plugin1",-1, 26367, 0, 16776960, -1, -1, -1, -1, -1, -1, -1, -1);

Example 2:

-- set colors in use = 5
-- and do not touch all of others
Gradient.SetColorSchema("Plugin1",5, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1, -1);


Gradient Plugin

Gradient.GetStyle()

table Gradient.GetStyle (string ObjectName);

Description:

Gets the shape's properties

ObjectName:

(string) The name of the object that you want to apply this action to.

Returns:

(table) A table containing properties of object .
If an error occurs, nil is returned.

Table Index As Following

(string)Table.Orientation : Specifies the current orientation of gradient this value can be
"HORIZONTAL" or "VERTICAL" or "B_DIAGONAL" or "F_DIAGONAL" or "NONE"
(number)Table.Color1 : Specifies the current color 1 for gradient this value can be Min = 0 or Max = 16777215
(number)Table.Color2 : Specifies the current color 2 for gradient this value can be Min = 0 or Max = 16777215
(number)Table.Color3 : Specifies the current color 3 for gradient this value can be Min = 0 or Max = 16777215
(number)Table.Color4 : Specifies the current color 4 for gradient this value can be Min = 0 or Max = 16777215
(number)Table.Color5 : Specifies the current color 5 for gradient this value can be Min = 0 or Max= 16777215
(number)Table.Color6 : Specifies the current color 6 for gradient this value can be Min = 0 or Max = 16777215
(number)Table.Color7 : Specifies the current color 7 for gradient this value can be Min = 0 or Max = 16777215
(number)Table.Color8 : Specifies the current color 8 for gradient this value can be Min = 0 or Max = 16777215
(number)Table.Color9 : Specifies the current color 9 for gradient this value can be Min = 0 or Max = 16777215
(number)Table.Color10 : Specifies the current color 10 for gradient this value can be Min = 0 or Max= 16777215
(number)Table.Color11 : Specifies the current color 11 for gradient this value can be Min = 0 or Max = 16777215
(number)Table.ColorsUsed : Specifies the number of colors in use this value can be Min = 2 or Max = 11
(number)Table.Border : Specifies the current border style in use this value can be 1 = shape has a border or 0 = shape has no border
(number)Table.BorderWidth : Specifies the current border width in use this value can be Min = 1 or Max = 10
(number)Table.BorderColor : Specifies the current border color this value can be Min = 0 or Max = 16777215

Example:

TBProperties = Gradient.GetStyle("Plugin1");
if (TBProperties ~= nil) then
local TmpOri = TBProperties.Orientation;
local TmpClr1 = TBProperties.Color1
local TmpClr2 = TBProperties.Color2
local TmpClr3 = TBProperties.Color3
local TmpClr4 = TBProperties.Color4
local TmpClr5 = TBProperties.Color5
local TmpClr6 = TBProperties.Color6
local TmpClrs = TBProperties.ColorsUsed
local TmpBord = TBProperties.Border
end


Gradient Plugin

Gradient.SetStyle()

Gradient.SetStyle (string ObjectName,string Orientation,number Border,number BorderWidth,number BorderColor);

Description:

Changes the shape's appearance

ObjectName:

(string) The name of the object that you want to apply this action to.

Orientation:

(string)Specifies the orientation of gradient. you can select one of following
HORIZONTAL = Horizontal Orientation
VERTICAL = Vertical Orientation
F_DIAGONAL = Forward Diagonal Orientation
B_DIAGONAL = Backward Diagonal Orientation
NONE = No Fill
or you can leave blank if you do not want to change this

Border:

(number)Specifies the new border style this value can be 1 = shape has a border or 0 = shape has no border.
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

BorderWidth

(number)Specifies the new border width this value can be Min = 1 or Max = 10
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

BorderColor:

(number)Specifies the new border color. you can select a (Decimal) color via color picker
or this parameter can be -1 if you do not want to change this value ( -1 Means Ignore )

Returns:

Nothing.

Example 1:

-- set border is visible and border color is black
Gradient.SetStyle("Plugin1", "", 1, -1, 0);

Example 2:

-- remove current fill
Gradient.SetStyle("Plugin1", "NONE", -1, -1, -1);