Introduction

 Top Next

Plugin Name:

VersionInfo

Current Version:

1,0,0,0 AMS8 Only

Description:

Just a simple plugin allowing you to obtain version information from executable windows binaries.

This plugin will extract all the available fields from the StringFileInfo structure in a binary, this means

it will not extract the default version information which you can simply obtain by using File.GetVersionInfo

Author:

Imagine Programming <Bas Groothedde>

Web:

www.imagine-programming.com

Contact:

contact@imagine-programming.com

Copyright:

© Imagine Programming, 2010.

Imagine Programming


Welcome

 Top Previous Next

Welcome to the helpfile for the Imagine VersionInfo Action Plugin (1.0)

Short help/description:

This helpfile will explain topics regarding the VersionInfo Action Plugin.

This is a real basic plugin allowing you to extract a table from the

StringFileInfo structure of a binary file.

Imagine Programming


About

 Top Previous Next

Imagine VersionInfo Action Plugin 1,0,0,0

Imagine Programming

- Bas Groothedde

www.imagine-programming.com

contact@imagine-programming.com

© Imagine Programming, 2010. All rights reserved.

Imagine VersionInfo Action Plugin

is a legal trademark by Imagine Programming.

Credits:

· Boku - For making me make it.

Imagine Programming


License

 Top Previous Next

Software license for Imagine VersionInfo Action Plugin.

This software and/or files are copyrighted to Imagine Programming and

Imagine Programming also claims full rights to this software.

This software is licensed to anyone for usage, this software is yours

to use/run and not to redistribute/reproduce.

This software is protected by copyright law and international treaties.

Unauthorized reproduction or distribution of this program, or any portion of it,

may result in severe civil and criminal penalties, and will be prosecuted under

the maximum extent possible under national and international law.

Redistribution

Redistribution is allowed, only when a direct link to the product's page is shown.

The products page for this product is http://imagine-programming.com/Product/20/.

You may not place a direct link to the file and you may not upload the file

yourself. If you wish to place your file on any website other as

www.imagine-programming.com, contact Imagine Programming with a request.

Email: contact@imagine-programming.com

Reproduction

Reproduction of any of the content of this software and/or files is strictly

forbidden by the international copyright law. Do not modify any of the included

files of this software package.

Warranty

The program IS DISTRIBUTED "AS IS". NO WARRANTY OF ANY KIND IS EXPRESSED OR

IMPLIED. YOU USE AT YOUR OWN RISK. NEITHER THE AUTHOR(S) NOR THE AGENTS OF THE

AUTHOR(S) WILL BE LIABLE FOR DATA LOSS, DAMAGES, LOSS OF PROFITS OR ANY OTHER KIND

OF LOSS WHILE USING OR MISUSING THIS SOFTWARE.

Again, legal measures will be taken in case of copyright infringement!

If you do not agree with the terms of this license you must remove Imagine VersionInfo Action Plugin

and all of it's files from your storage devices and cease to use the product.

Imagine Programming


VersionInfo.GetInfo

 Top Previous

Description

Obtains the StringFileInfo structure from a windows binary and returns it as a table.

This function also extracts all additional/extra fields the author has added that are

not usually added to files. Eg. Comments/Note/Credits/Hello World.

Anything is possible.

If you want the regular version info, use File.GetVersionInfo. This function extracts

all information from the StringFileInfo structure and not the main version info structure.

This means, the basic information (numeric file/product version) will not be extracted

using this function.

Parameters

Type | Name | Description
String | Filepath | A path to a valid file containing file information, like for example a Windows Executable (Exe), Dynamic-link Library (Dll)

Return Value

Table

This function returns a table containing x amount of version info fields.

The table if formatted the next way:

tTable[1] = {FieldName = "Company", FieldValue = "Imagine Programming"}

tTable[2] = {FieldName = "Website", FieldValue = "www.imagine-programming.com"}

etc...

This function returns nil if the file was not found or did not contain any information.

Example

local tVerInfo = VersionInfo.GetInfo(_SystemFolder.."\\shell32.dll");
if(tVerInfo~=nil)then
  for i, tInfo in pairs(tVerInfo)do
    ListBox.AddItem("ListBox1", tInfo.FieldName.." = "..tInfo.FieldValue, "");
  end
end

Imagine Programming